Fedora

Mais qu'est-ce qui se cache derrière ce nom barbare ? Un univers riche, qu'il ne tient qu'a vous de découvrir ...
Avatar du membre
Guepi
Administrateur
Administrateur
Messages : 518
Enregistré le : 28 novembre 2009, 00:55
Localisation : Lille

Re: Fedora

Message par Guepi » 16 novembre 2011, 12:33

Ah ben voilà ... je suis trop pressé !!!

Sur les forum, le problème est remonté plusieurs fois : soit SELinux en est la cause, soit le driver NVidia.

J'ai fait la manip pour vérifier si SELinux en était la cause:

Code : Tout sélectionner

#init 3
#setenforce 0 
#startx
Même punition : "Oh mince !"

Donc le hic provient du driver nvidia. Je verrais pour un update du driver ce soir ou demain.

Avatar du membre
McDoul
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 71
Enregistré le : 12 février 2009, 20:46

Re: Fedora

Message par McDoul » 17 novembre 2011, 02:14

Regarde les logs jeune padawan et arrête la divination :papy:

Avatar du membre
Guepi
Administrateur
Administrateur
Messages : 518
Enregistré le : 28 novembre 2009, 00:55
Localisation : Lille

Re: Fedora

Message par Guepi » 29 novembre 2011, 19:06

Les logs, Mc Doul ne m'ont guère aidé.

Seul les traces système aurait pu m'aider. :penseur:

Bref, un coup de

Code : Tout sélectionner

yum check
qui indique qu'il y a un soucis sur le package gnome-shell.
Et hop, un

Code : Tout sélectionner

yum reinstall gnome-shell
Et ce fut parti !!!

Et surtout on n'oublie pas :

Code : Tout sélectionner

yum update selinux* --enablerepo=updates-testing

Avatar du membre
Guepi
Administrateur
Administrateur
Messages : 518
Enregistré le : 28 novembre 2009, 00:55
Localisation : Lille

Re: Fedora

Message par Guepi » 08 décembre 2011, 13:49

Le système est très stable :tropfort:

Le hic, c'est que lorsque BOINC utilise le GPU, l'affichage est extrêmement ralenti.
Mon ma petite nVidia (GTS 250 de mémoire) doit pas "tenir" le coup entre CUDA et Gnome 3.2 :nico5:
Donc je désactive le GPU lorsque j'utilise mon PC.

Avatar du membre
Pascal94
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 654
Enregistré le : 16 mai 2009, 13:43
Localisation : France (94)
Contact :

Re: Fedora

Message par Pascal94 » 30 janvier 2012, 21:25

salut Guepi :coucou:

une ch'tite question : je viens d'installer Boinc, en utilisant le sh de Berkeley

lorsque je fais un LDD sur boinc, voici ce qu'il m'affiche :

Code : Tout sélectionner

ldd boinc
./boinc: /usr/lib64/libcurl.so.4: no version information available (required by ./boinc)
	linux-vdso.so.1 =>  (0x00007fffbd3c0000)
	libcurl.so.4 => /usr/lib64/libcurl.so.4 (0x00000036e1e00000)
	libssl.so.1.0.0 => not found
	libcrypto.so.1.0.0 => not found
	libdl.so.2 => /lib64/libdl.so.2 (0x00000031fba00000)
	libz.so.1 => /lib64/libz.so.1 (0x00000031fd200000)
	libXss.so.1 => /usr/lib64/libXss.so.1 (0x00007fa1f6055000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00000031fb600000)
	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x0000003207600000)
	libm.so.6 => /lib64/libm.so.6 (0x00000031fc200000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00000031fc600000)
	libc.so.6 => /lib64/libc.so.6 (0x00000031fb200000)
	libX11.so.6 => /usr/lib64/libX11.so.6 (0x00000031ff200000)
	libidn.so.11 => /lib64/libidn.so.11 (0x0000003213200000)
	liblber-2.4.so.2 => /usr/lib64/liblber-2.4.so.2 (0x000000320fe00000)
	libldap-2.4.so.2 => /usr/lib64/libldap-2.4.so.2 (0x0000003210e00000)
	librt.so.1 => /lib64/librt.so.1 (0x00000031fbe00000)
	libgssapi_krb5.so.2 => /lib64/libgssapi_krb5.so.2 (0x000000320c200000)
	libkrb5.so.3 => /lib64/libkrb5.so.3 (0x000000320c600000)
	libk5crypto.so.3 => /lib64/libk5crypto.so.3 (0x000000320ca00000)
	libcom_err.so.2 => /lib64/libcom_err.so.2 (0x000000320a200000)
	libssl3.so => /usr/lib64/libssl3.so (0x0000003209a00000)
	libsmime3.so => /usr/lib64/libsmime3.so (0x0000003209e00000)
	libnss3.so => /usr/lib64/libnss3.so (0x0000003209600000)
	libnssutil3.so => /usr/lib64/libnssutil3.so (0x0000003209200000)
	libplds4.so => /lib64/libplds4.so (0x0000003208a00000)
	libplc4.so => /lib64/libplc4.so (0x0000003208e00000)
	libnspr4.so => /lib64/libnspr4.so (0x0000003208600000)
	libssh2.so.1 => /usr/lib64/libssh2.so.1 (0x0000003213a00000)
	/lib64/ld-linux-x86-64.so.2 (0x00000031fae00000)
	libXext.so.6 => /usr/lib64/libXext.so.6 (0x00000031ffe00000)
	libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00000031ffa00000)
	libresolv.so.2 => /lib64/libresolv.so.2 (0x00000031fd600000)
	libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x000000320ee00000)
	libkrb5support.so.0 => /lib64/libkrb5support.so.0 (0x000000320ba00000)
	libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x000000320ae00000)
	libssl.so.10 => /usr/lib64/libssl.so.10 (0x000000320e600000)
	libcrypto.so.10 => /lib64/libcrypto.so.10 (0x000000320a600000)
	libXau.so.6 => /usr/lib64/libXau.so.6 (0x00000031ff600000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x0000003206e00000)
	libselinux.so.1 => /lib64/libselinux.so.1 (0x00000031fca00000)
	libfreebl3.so => /lib64/libfreebl3.so (0x0000003207200000)
bash-4.2$ 
pourtant, Opensssl-1.0.0g est installé, et j'ai bien libssl et libcrypto dans /usr/lib64/

:penseur:
« Je ne sais pas quelles armes seront utilisées pour la troisième guerre mondiale, si elle a lieu. Mais la quatrième se règlera à coups de massues. » {Albert Einstein}

Avatar du membre
Guepi
Administrateur
Administrateur
Messages : 518
Enregistré le : 28 novembre 2009, 00:55
Localisation : Lille

Re: Fedora

Message par Guepi » 30 janvier 2012, 23:02

Très honnêtement, je prends Boinc toujours à travers le Yellow dog Updater Modified (YUM).

Ce problème est connu et sa résolution reviens à priori à installer boinc à travers l'outil intégré de Fedora.

Avatar du membre
Pascal94
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 654
Enregistré le : 16 mai 2009, 13:43
Localisation : France (94)
Contact :

Re: Fedora

Message par Pascal94 » 31 janvier 2012, 08:03

dans les dépôts il n'y a que la version 6.12.35

comment faire pour installer la version 7.0.12 par exemple ?

je t'avoue que je ne connais pas encore Yum :sifflote:
« Je ne sais pas quelles armes seront utilisées pour la troisième guerre mondiale, si elle a lieu. Mais la quatrième se règlera à coups de massues. » {Albert Einstein}

Avatar du membre
Guepi
Administrateur
Administrateur
Messages : 518
Enregistré le : 28 novembre 2009, 00:55
Localisation : Lille

Re: Fedora

Message par Guepi » 31 janvier 2012, 20:25

Pascal94 a écrit :dans les dépôts il n'y a que la version 6.12.35

comment faire pour installer la version 7.0.12 par exemple ?

je t'avoue que je ne connais pas encore Yum :sifflote:
Cette "vieille" version dans les dépôts est validée pour Fedora.
Si tu souhaite une version plus à jour, je te conseille d'abord de tester dans une machine virtuelle.
Il faudra certainement mettre à jour plusieurs librairies.

Yum, c'est un peu le gestionnaire de paquets de Ubuntu.

Avatar du membre
jip
Administrateur
Administrateur
Messages : 2607
Enregistré le : 22 février 2008, 21:00
Localisation : Toulouse
Contact :

Re: Fedora

Message par jip » 31 janvier 2012, 23:50

yumex pour le gui (pour le mode gros fainéant), non ? comme j'ai mis sur centos. ça doit aussi passer sur fedora je suppose.
Un synonyme, c'est un mot qu'on écrit pour remplacer celui dont on ne connait pas l'orthographe. (source inconnue). L'imagination est plus importante que le savoir. (Albert Einstein)

[align=center]Image[/align]

BoincLibristes, FreeTorrent, Ma brute

Avatar du membre
Guepi
Administrateur
Administrateur
Messages : 518
Enregistré le : 28 novembre 2009, 00:55
Localisation : Lille

Re: Fedora

Message par Guepi » 01 février 2012, 00:46

jip a écrit :yumex pour le gui (pour le mode gros fainéant), non ? comme j'ai mis sur centos. ça doit aussi passer sur fedora je suppose.
yumex est inconnu sous Fedora, mais l'interface graphique pour ajouter/supprimer des programmes existe bel et bien : c'est gpk-application (du moins sous Gnome).

:tchin:

Avatar du membre
Pascal94
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 654
Enregistré le : 16 mai 2009, 13:43
Localisation : France (94)
Contact :

Re: Fedora

Message par Pascal94 » 01 février 2012, 12:05

j'avais déjà testé Yumex en fin d'année, mais le gestionnaire de paquets de Fedora me va très bien :jap:

pour le moment, je n'ai qu'une utilisation "basique" de Fedora :grin:

je repense à Boinc, en créant des liens symboliques y'aurait-il pas moyen de faire tourner une version 7 ? :penseur:

avec mon niveau, ça va être dur, faut que cherche du coté du fofo Fedora-fr voir si quelqu'un s'est déjà lancé là dedans :lol:

au passage, ça fera remonter le topic sur Boinc, enfin j'espère...
« Je ne sais pas quelles armes seront utilisées pour la troisième guerre mondiale, si elle a lieu. Mais la quatrième se règlera à coups de massues. » {Albert Einstein}

Avatar du membre
Guepi
Administrateur
Administrateur
Messages : 518
Enregistré le : 28 novembre 2009, 00:55
Localisation : Lille

Re: Fedora

Message par Guepi » 01 février 2012, 13:34

Mon cher Pascal, je ferais bien le nécessaire pour faire tourner Boinc 7 sous Fedora, mais je manque "cruellement" de temps.
:sifflote:

Si j'ai du temps à tuer dans les semaines à venir, je monte une image Fedora 16 et lance une install de Boinc 7 via le sh de Berkeley.
C'est celui-ci (Linux 32 bits) : http://boinc.berkeley.edu/dl/boinc_7.0. ... nux-gnu.sh
ou celui-ci (Linux 64 bits) : http://boinc.berkeley.edu/dl/boinc_7.0. ... nux-gnu.sh

Avatar du membre
Pascal94
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 654
Enregistré le : 16 mai 2009, 13:43
Localisation : France (94)
Contact :

Re: Fedora

Message par Pascal94 » 01 février 2012, 19:31

salut Guepi :coucou:

hé je te mets pas le couteau sous la gorge, hein :jap:

comme j'ai vu un topic dédié au calcul distribué sur Boinc sur le forum Fedora-fr, j'y ai reporté ce problème, mais bon, le topic ne fait qu'une seule page, c'est dire s'il est populaire ou suivi :prr:

A ce que j'ai compris de la réponse d'Ageless, les scripts de Berkley sont étaient construits sur Ubuntu, et de ce fait il faut que les librairies soient installées selon la même arborescence que sous Ubuntu. C'est pourquoi je me posais la question de savoir si ça ne pouvait pas être contourné par des liens ?

Autre point important de sa réponse, c'est que le dev chargé des versions Linux est parti en live, et qu'il a été banni des forums :sad:

Enfin bon, dans les depots Fedora y'a la version 6.12.35, alors que sur le site de Boinc ils proposent la 6.12.34, comme quoi... :grin:
« Je ne sais pas quelles armes seront utilisées pour la troisième guerre mondiale, si elle a lieu. Mais la quatrième se règlera à coups de massues. » {Albert Einstein}

Avatar du membre
Guepi
Administrateur
Administrateur
Messages : 518
Enregistré le : 28 novembre 2009, 00:55
Localisation : Lille

Re: Fedora

Message par Guepi » 02 février 2012, 00:33

Je pense à toi :

Image

Avatar du membre
Pascal94
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 654
Enregistré le : 16 mai 2009, 13:43
Localisation : France (94)
Contact :

Re: Fedora

Message par Pascal94 » 02 février 2012, 20:02

:calin: :calin: :calin:
« Je ne sais pas quelles armes seront utilisées pour la troisième guerre mondiale, si elle a lieu. Mais la quatrième se règlera à coups de massues. » {Albert Einstein}

Répondre