deconnexion automatique?

Une opinion, une idée, quelque chose à améliorer ? Exprimez vous ici
eartells
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 32
Enregistré le : 02 avril 2008, 21:17
Localisation : Catalogne
Contact :

deconnexion automatique?

Message par eartells » 01 septembre 2011, 10:24

Bonjour, et re-bonjour

juste j'aimerai savoir s'il y a un bug quelque part du fait que quand je parcour le forum, tous les 2 minutes je dois me reconnecter.

sinon, je suis desolée d'être disparue si longtemps et si quelqu'un à quelque chose à me dire, veuillez bien désormais vous adresser à Dr. eartells :tuxwin: :tuxwin:

Avatar du membre
jip
Administrateur
Administrateur
Messages : 2607
Enregistré le : 22 février 2008, 21:00
Localisation : Toulouse
Contact :

Re: deconnexion automatique?

Message par jip » 01 septembre 2011, 10:25

C'est peut-être un effet de bord du passage en https et de l'option cookie sécurisé.

je vais regarder à l'occasion ..
Un synonyme, c'est un mot qu'on écrit pour remplacer celui dont on ne connait pas l'orthographe. (source inconnue). L'imagination est plus importante que le savoir. (Albert Einstein)

[align=center]Image[/align]

BoincLibristes, FreeTorrent, Ma brute

Avatar du membre
jip
Administrateur
Administrateur
Messages : 2607
Enregistré le : 22 février 2008, 21:00
Localisation : Toulouse
Contact :

Re: deconnexion automatique?

Message par jip » 01 septembre 2011, 10:55

bon on dirait bien que c'est ça le pb : http://forums.phpbb-fr.com/support-util ... 74934.html

je vais continuer pour voir si y'a des solutions.

sinon, je fais quoi ? je laisse ou je désactive ?


edit : enfin bon, tout le monde peut chercher si y'a une solution pour ce pb de cookie sécurisé sur phpbb3 aussi. je suis pas le seul à pouvoir le faire ... chacun doit savoir chercher avec un moyeur sur le web je pense .... :sifflote:
Un synonyme, c'est un mot qu'on écrit pour remplacer celui dont on ne connait pas l'orthographe. (source inconnue). L'imagination est plus importante que le savoir. (Albert Einstein)

[align=center]Image[/align]

BoincLibristes, FreeTorrent, Ma brute

Avatar du membre
Elgrande71
Administrateur
Administrateur
Messages : 1709
Enregistré le : 29 février 2008, 10:24
Localisation : Le Creusot
Contact :

Re: deconnexion automatique?

Message par Elgrande71 » 01 septembre 2011, 13:43

Suite à un MP de jip concernant un problème d'accès à notre portail,
j'ai dû rajouter un paramètre pour le serveur web apache2.
L'accès à notre portail est rétabli.
J'espère que cela réglera aussi ton problème eartells :wink:
Debian - Distribution GNU/Linux de référence
Parabola GNU/Linux - Distribution GNU/Linux Libre
Solus
Tux'N'Vape - Manjaro Tux'N'Vape

Avatar du membre
Guepi
Administrateur
Administrateur
Messages : 518
Enregistré le : 28 novembre 2009, 00:55
Localisation : Lille

Re: deconnexion automatique?

Message par Guepi » 02 septembre 2011, 07:49

Salut tout le monde !

Je subi ce problème de déconnexion :
j'ai un lien dans ma barre de marques-pages, qui pointe sur l'adresse : http://libristes-forum.boinc-af.net/sea ... d=newposts

Depuis hier, si j'utilise ce lien, je suis déconnecté.

Par contre, si j'utilise le lien idoine du forum (Consulter les nouveaux messages - http://libristes-forum.boinc-af.net/sea ... s&sid=xxxx) je peux continuer ma navigation.

Avatar du membre
nico8313
Modérateur Global
Modérateur Global
Messages : 2228
Enregistré le : 29 mai 2008, 14:59
Localisation : VAR
Contact :

Re: deconnexion automatique?

Message par nico8313 » 02 septembre 2011, 10:00

eartells a écrit :Bonjour, et re-bonjour
sinon, je suis désolée d'être disparue si longtemps et si quelqu'un à quelque chose à me dire, veuillez bien désormais vous adresser à Dr. eartells :tuxwin: :tuxwin:

:coucou: Coucou Eartells

Tu as réussi !!! alors félicitation à notre Docteur :tchin: :tchin: :tchin: :tuxwin:
Tu es toujours la bienvenue ici :fccpu:

Avatar du membre
dudumomo
Administrateur
Administrateur
Messages : 2175
Enregistré le : 11 mars 2008, 14:42
Localisation : Taipei
Contact :

Re: deconnexion automatique?

Message par dudumomo » 05 septembre 2011, 14:51

Tiens moi ca foire toujours....
Je suis le seul ?
News & Tutorials on opensource software ==> freedif.org
Idipops, réseau social des prestataires de services.

Avatar du membre
Gillou40
Administrateur
Administrateur
Messages : 690
Enregistré le : 20 juin 2010, 07:40
Localisation : Mont de Marsan
Contact :

Re: deconnexion automatique?

Message par Gillou40 » 05 septembre 2011, 15:30

Non Dudumomo, je suis obligé de me connecter à chaque fois que je vais sur le forum.

J'ai d'abord cru à un problème de cookie, mais j'ai essayé avec Firefox, Chromium, et même Internet Explorer (c'est dire comme je suis désespéré!), pas mieux.
Image

Avatar du membre
jip
Administrateur
Administrateur
Messages : 2607
Enregistré le : 22 février 2008, 21:00
Localisation : Toulouse
Contact :

Re: deconnexion automatique?

Message par jip » 05 septembre 2011, 15:37

Ah ...

moi depuis la modif de configuration du serveur faite par elgrande, ça va beaucoup mieux.

Juste que la connexion automatique dure un peu moins longtemps qu'avant.

Je suppose que le cookie se périme plus vite avec l'option de cookie sécurisé. Surement voulu par les concepteurs.
Un synonyme, c'est un mot qu'on écrit pour remplacer celui dont on ne connait pas l'orthographe. (source inconnue). L'imagination est plus importante que le savoir. (Albert Einstein)

[align=center]Image[/align]

BoincLibristes, FreeTorrent, Ma brute

eartells
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 32
Enregistré le : 02 avril 2008, 21:17
Localisation : Catalogne
Contact :

Re: deconnexion automatique?

Message par eartells » 05 septembre 2011, 15:39

dudumomo a écrit :Tiens moi ca foire toujours....
Je suis le seul ?
moi ça dépend du jour et l'heure. Ce matin, pas fait. Mantenant, oui.

Avatar du membre
Guepi
Administrateur
Administrateur
Messages : 518
Enregistré le : 28 novembre 2009, 00:55
Localisation : Lille

Re: deconnexion automatique?

Message par Guepi » 06 septembre 2011, 01:01

Gillou40 a écrit :Non Dudumomo, je suis obligé de me connecter à chaque fois que je vais sur le forum.

J'ai d'abord cru à un problème de cookie, mais j'ai essayé avec Firefox, Chromium, et même Internet Explorer (c'est dire comme je suis désespéré!), pas mieux.
Tu as essayé en HTTPS uniquement ?
Perso, ça venait de là. :tchin:

Avatar du membre
dudumomo
Administrateur
Administrateur
Messages : 2175
Enregistré le : 11 mars 2008, 14:42
Localisation : Taipei
Contact :

Re: deconnexion automatique?

Message par dudumomo » 06 septembre 2011, 06:35

Je viens de regarder ce probleme.

On perd le cookie securise quand on passe du HTTPS au HTTP.
En fait l'authentification passe par le HTTPS. Si on revient sur le site en HTTP et bien ca ne fonctionne pas. Si on passe par le HTTPS. Aucun soucis.

Concernant cette perte de cookie...j'ai un peu du mal a comprendre d'ou ca vient.

J'aurai tout de meme une question pour Elgrande (Jip doit surement savoir aussi)
On aurai pas suhosin d'installe ? (Si oui, faudrait regarder la variable suhosin.session.cryptdocroot) Ca peut venir de la.

Sinon, une solution serait de passer le forum au tout HTTPS.
News & Tutorials on opensource software ==> freedif.org
Idipops, réseau social des prestataires de services.

Avatar du membre
Gillou40
Administrateur
Administrateur
Messages : 690
Enregistré le : 20 juin 2010, 07:40
Localisation : Mont de Marsan
Contact :

Re: deconnexion automatique?

Message par Gillou40 » 06 septembre 2011, 07:26

:plusun: Dudumomo

Mon favori https ne me déconnecte plus. Avant je passais par l'index du forum, et là reconnexion obligatoire !
Image

eartells
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 32
Enregistré le : 02 avril 2008, 21:17
Localisation : Catalogne
Contact :

Re: deconnexion automatique?

Message par eartells » 06 septembre 2011, 08:54

j'ai vu une rélation entre déconnexion et link d'un mail. À chaque fois que j'ouvre un mail du forum et me disant qu'il y a une nouvelle réponse, je crois que si le link m'envoie sur la "zone privé" je reste connecté dans la nouvelle fenetre, si je vais vers une partie non privé, je dois me reconnecter.

en fin, je crois que c'est comme ça que ça arrive

Avatar du membre
ignace72
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 51
Enregistré le : 14 juillet 2011, 19:10
Contact :

Re: deconnexion automatique?

Message par ignace72 » 03 novembre 2011, 21:01

GRRRR
Je n'écris pas vite.
Souvent je m’aperçois de la déconnexion au moment ou je clic sur Prévisualiser ou envoyer.
Résultat : message vide.
dernier en date, il y a 3 mn, 10 lignes perdu.
Ça m’énerve de devoir écrire mes messages sur kwrite avant et les coller pour les poster !
Image
Version de Boinc : 6.10.58
Achlinux / windows 8.
Phenom II X6 1100T, 4 Go Ram DDR3, ATI HD4670.
écrans 21,5" 16/9 LCD et 19" 4/3 CRT

Répondre