[RESOLU] CUDA & Ubuntu-Server

Posez ici toutes les questions ou les soucis que vous rencontrez avec linux,nous tenterons avec vous de les resoudre
Répondre
Avatar du membre
kdrt
Novice
Novice
Messages : 24
Enregistré le : 27 décembre 2010, 19:02

[RESOLU] CUDA & Ubuntu-Server

Message par kdrt » 10 janvier 2011, 02:52

Bonjour,

J'ai quelques questions quant au fonctionnement de CUDA sur Ubuntu-Server 10.10 x64.

J'avais une 8500GT qui trainait et que j'ai installée dans mon serveur que j'utilise exclusivement via SSH (console, pas d'écran, ni de x server). Malheureusement lorsque je regarde les messages (via BoincTasks) de mon serveur, je vois ceci : "No usable GPUs found".

Pourrait-on me guider afin de pouvoir cruncher avec mon gpu ?
La seule chose que je voudrais éviter c'est d'installer x server, gnome et tout ce qui peut se rapporter aux gui. Ca reste un serveur. :grin:
Mais je ne sais pas si c'est possible de cruncher avec un gpu sans gui. :confus:

Et puis avant que j'oublie; la question subsidiaire : quels sont projets les plus rentables pour le couple GNU/Linux + Nvidia ?

Merci d'avance. :jap:
Modifié en dernier par kdrt le 10 janvier 2011, 15:13, modifié 1 fois.

Avatar du membre
dudumomo
Administrateur
Administrateur
Messages : 2170
Enregistré le : 11 mars 2008, 14:42
Localisation : Taipei
Contact :

Re : CUDA & Ubuntu-Server

Message par dudumomo » 10 janvier 2011, 05:53

Alors je commence a repondre par la question la plus simple:
- Projet le + rentable a l'heure actuelle pour le couple GNU/Linux + Nvidia = PRIMEGRID et de loin. (En revanche, je ne sais pas si une 8500GT peut cruncher dessus...je n'ai pas en tete les conditions minimales.

En revanche, pour ce qui est de cruncher sans interface graphique...ca va etre difficile.
Primo, pour que BOINC puisse utiliser ton GPU, il faut qu'il le detecte comme capable de calculer (Ie, il te faut des drivers assez recent)
Secondo, il faut que la carte graphique soit "active" comme par exemple en lancant Xorg.

Elgrande avait reussi a faire calculer quelques CG sans interface graphique (Mais ca n'avait pas fonctionne avec sa 8800GTS), via la creation de nodes.
Ca reste quand meme assez compliquer. (Cf son tuto)
News & Tutorials on opensource software ==> freedif.org
Idipops, réseau social des prestataires de services.

Avatar du membre
Gillou40
Administrateur
Administrateur
Messages : 690
Enregistré le : 20 juin 2010, 07:40
Localisation : Mont de Marsan
Contact :

Re : Re : CUDA & Ubuntu-Server

Message par Gillou40 » 10 janvier 2011, 08:12

dudumomo a écrit :En revanche, je ne sais pas si une 8500GT peut cruncher dessus...je n'ai pas en tete les conditions minimales.


Tout dépend si la 8500GT possède 256 ou 512Mo (elle existe en deux versions DDR2), je crois qu'en dessous de 512Mo, il ne faut pas y penser.
Image

Avatar du membre
kdrt
Novice
Novice
Messages : 24
Enregistré le : 27 décembre 2010, 19:02

Re : Re : Re : CUDA & Ubuntu-Server

Message par kdrt » 10 janvier 2011, 15:13

Super ! Merci pour vos réponses.
Mon serveur (bind,ntp,lamp,boinc/cpu) a crashé à cause -sans doute- du matériel vieillissant.
Afin de rentabiliser au plus vite le matériel, j'ai déplacé ma carte graphique dans une configuration Ubuntu x64 Desktop qui est allumé 24/7. (Pourquoi je n'y ai pas pensé plus tôt ?)

Après installation du driver recommandé voici ce que Boinc me dit :
[code="Message dans Boinc"]NVIDIA GPU 0: GeForce 8500 GT (driver version unknown, CUDA version 3020, compute capability 1.1, 255MB, 29 GFLOPS peak)[/code]

Rattachement le projet, téléchargement des applications, et voilà ça crunch.

Ca ne crunch pas à vitesse c mais ça crunch...

En tout cas je vous remercie.



Voici ce que j'ai trouvé comme infos utiles.

PrimeGrid : configuration minimale GPU CUDA/Nvidia
Nvidia : CUDA working on ubuntu-desktop not on ubuntu-server
Modifié en dernier par kdrt le 10 janvier 2011, 16:11, modifié 1 fois.

Avatar du membre
nico8313
Modérateur Global
Modérateur Global
Messages : 2228
Enregistré le : 29 mai 2008, 14:59
Localisation : VAR
Contact :

Re : [RESOLU] CUDA & Ubuntu-Server

Message par nico8313 » 10 janvier 2011, 20:39

:hello:

La mémoire vidéo utilisé par primegrid c'est 148Mo !
C'est  les GPU avec seulement 128Mo qui sont dans la merde  :grin:

Répondre