[RÉSOLU] Pas de lancement de BOINC

Posez ici toutes les questions ou les soucis que vous rencontrez avec linux,nous tenterons avec vous de les resoudre
Répondre
Avatar du membre
Pascal
CàA MT Libristes
CàA MT Libristes
Messages : 722
Enregistré le : 16 novembre 2009, 15:44
Localisation : Toulon (Var)
Contact :

[RÉSOLU] Pas de lancement de BOINC

Message par Pascal » 13 avril 2011, 02:47

:hello: à tous,

Depuis ma nouvelle installation d'ubuntu 10.10 version light (lubuntu), je ne peux plus lancer BOINC, ni les fichiers sh, bash ...
Mon BOINC 6.10.58 est installé par le fichier .sh de boincstats depuis sa sortie dans un répertoire du bureau.

Je le lançais dans un terminal par "cd Bureau/BOINC" puis "sudo ./boinc" et ça partait.
Maintenant, j'ai ça comme réponse :

Code : Tout sélectionner

xxxx:~$ cd Bureau/BOINC
xxxx:~/Bureau/BOINC$ sudo ./boinc
[sudo] password for xxxx: 
./boinc: ./boinc : fichier binaire impossible à lancer
xxxx:~/Bureau/BOINC$ 
Si j'essaye de lancer le run_client j'ai ça :

Code : Tout sélectionner

xxxx:~/Bureau/BOINC$ sudo ./run_client
./run_client: line 1: /home/xxxx/Bureau/BOINC/boinc : fichier binaire impossible à lancer
./run_client: line 1: /home/xxxx/Bureau/BOINC/boinc: Succès
xxxx:~/Bureau/BOINC$ 
et rien ne se passe.

Il n'est pas possible également de refaire une installation de BOINC avec boinc_6.10.58_x86_64-pc-linux-gnu.sh, hormis via les dépôts, peut-être, mais cela ne résoudrait rien pour les autres fichiers .sh que je ne peux pas lancer.

Je suis propriétaire et ai mis les droits 777 à tout le répertoire BOINC et la case exécutable est bien cochée.

Si ça inspire quelqu'un, j'en serais ravi.
Modifié en dernier par Pascal le 14 avril 2011, 16:21, modifié 1 fois.
"Le devoir du présent, c'est d'être le bienfaiteur de l'avenir." Jules Verne
Image
Profitez de la recherche partagée avec YaCy

Avatar du membre
dudumomo
Administrateur
Administrateur
Messages : 2180
Enregistré le : 11 mars 2008, 14:42
Localisation : Taipei
Contact :

Re : Pas de lancement de BOINC

Message par dudumomo » 13 avril 2011, 06:51

C'est assez etrange...
La commande sh /home/pascalouuu/Bureau/Boinc.xxxx.sh ne fonctionne pas ? Meme erreur ?

En fait, j'ai l'impression que c'est lie a ton installation.... tu avais separe le /home avant et tu l'as recupere ?
Regarde dans ton fstab si tu peux exectuer sur la partition en question.
News & Tutorials on opensource software ==> freedif.org
Idipops, réseau social des prestataires de services.

Avatar du membre
Pascal
CàA MT Libristes
CàA MT Libristes
Messages : 722
Enregistré le : 16 novembre 2009, 15:44
Localisation : Toulon (Var)
Contact :

Re : Pas de lancement de BOINC

Message par Pascal » 13 avril 2011, 09:21

dudumomo a écrit : C'est assez etrange...
N'est-ce pas !
La commande sh /home/pascalouuu/Bureau/Boinc.xxxx.sh ne fonctionne pas ? Meme erreur ?
Pas tout à fait.
Il m'a créé un nouveau dossier /home/pascalouuu/BOINC avec les fichiers BOINC de l'installation.
Par contre, pour le lancement du client ou du manager, c'est pareil : "fichier binaire impossible à lancer"
En fait, j'ai l'impression que c'est lie a ton installation.... tu avais separe le /home avant et tu l'as recupere ?
Oui, le /home est sur un disque et partition à part. je l'ai déclaré lors de l'installation, son point de montage est /home d'origine, ce n'est pas une manip faite après installation.
Regarde dans ton fstab si tu peux exectuer sur la partition en question.
Je ne sais pas si je peux exécuter sur la partition, mais c'est la même chose que dans le fstab de l'ancienne installation, c'est à dire avec les valeurs:

UUID=blablabla    /home          ext4    defaults        0      2
Dois-je changer quelque chose ?
"Le devoir du présent, c'est d'être le bienfaiteur de l'avenir." Jules Verne
Image
Profitez de la recherche partagée avec YaCy

Avatar du membre
Guepi
Administrateur
Administrateur
Messages : 518
Enregistré le : 28 novembre 2009, 00:55
Localisation : Lille

Re : Pas de lancement de BOINC

Message par Guepi » 13 avril 2011, 12:22

à la réinstall de mon système, il s'est réapproprié tout le /home (j'ai mis le même user sur ma nouvelle install que sur l'ancienne).

peut-être un :

Code : Tout sélectionner

#chown -R pascalouuu /home

Avatar du membre
Pascal
CàA MT Libristes
CàA MT Libristes
Messages : 722
Enregistré le : 16 novembre 2009, 15:44
Localisation : Toulon (Var)
Contact :

Re : Pas de lancement de BOINC

Message par Pascal » 13 avril 2011, 20:40

Merci Guepi, j'ai fait une install via les dépôts et ça marche.

Je pense que peut-être quand j'ai fait l'install, la version lubuntu doit être en 32 bits alors que j'étais en ubuntu_amd_64.
Les fichiers binaires ne doivent pas être les mêmes et j'essayai d'installer la version 64 bits de BOINC comme j'en avais l'habitude.

Je n'ai pas trouvé de distri lubuntu amd_64. Ça n'existe peut-être pas.
Je vais refaire une install d'ubuntu 10.04_amd_64, comme avant puis j'installerai le paquet lubuntu car j'aime bien lxde, c'est moins sophistiqué que gnome.
Modifié en dernier par Pascal le 14 avril 2011, 16:16, modifié 1 fois.
"Le devoir du présent, c'est d'être le bienfaiteur de l'avenir." Jules Verne
Image
Profitez de la recherche partagée avec YaCy

Avatar du membre
Pascal
CàA MT Libristes
CàA MT Libristes
Messages : 722
Enregistré le : 16 novembre 2009, 15:44
Localisation : Toulon (Var)
Contact :

Re : Pas de lancement de BOINC

Message par Pascal » 14 avril 2011, 16:20

C'était bien ça, j'ai refait l'install d'ubuntu 64 et mon BOINC refonctionne correctement.
Avec l'habitude de ne pas avoir de choix à faire avec les dépôts que je n'ai pas fait attention que je téléchargeais la version lubuntu 32 bits, d'ailleurs, je n'ai toujours pas trouvé de version 64 bits.
Merci à tous.
"Le devoir du présent, c'est d'être le bienfaiteur de l'avenir." Jules Verne
Image
Profitez de la recherche partagée avec YaCy

Répondre