[Résolu] Contrôle distant d'un client Boinc

Posez ici toutes les questions ou les soucis que vous rencontrez avec linux,nous tenterons avec vous de les resoudre
Avatar du membre
cottesloe
Modérateur Global
Modérateur Global
Messages : 329
Enregistré le : 23 juin 2010, 13:34
Localisation : Petersbach

[Résolu] Contrôle distant d'un client Boinc

Message par cottesloe » 02 juin 2012, 16:19

Salut à tous.

Je viens voir si quelqu'un peu m'aider à résoudre un petit soucis.

Je souhaite prendre le contrôle d'un de mes PC par un autre, en local, via VNC.
Jusque là, facile...
Sauf que, le PC serveur me donne une erreur de segmentation à chaque connexion du PC client.
Et j'ai beau chercher sur le web, les forum et tout et tout, je ne trouve rien de probant...

Conf:
- PC client: Ubuntu 12.04, Core2 Duo 3GHz, 4Go ram, avec Vinagre et Remina (j'ai essayé les deux...)
- PC serveur: Lubuntu 12.04 Celeron 1GHz 500Mo ram (vous marrez pas... :sifflote: ) avec Vino

L'idée générale, c'est d'utiliser le vieux Celeron pour le capteur Radioactive@home sans lui adjoindre un ensemble écran clavier souris. Je le colle dans un coin, et je ne m'en occupe plus. Et pour le gérer, je fais ça de mon PC usuel.
Ça fait une semaine que le Celeron fait tourner le capteur R@h, donc ça c'est bon.
Et je bloque sur ce contrôle à distance... :furax:

Une autre possibilité serait de lui installer une version serveur, et de faire tout par SSH. J'ai essayé, ça marche. Sauf que je ne sais pas gérer Boinc en ligne de commande... :run: => SORTIE
Ça peux être un bon moyen de m'y mettre aussi... :sifflote: :penseur:
Image
"Je sers la science et c'est ma joie"  Disciplus Simplex
Boinceur sous Archlinux 64 bits
La meilleure émission de radio, c'est la planète bleue

Avatar du membre
nico8313
Modérateur Global
Modérateur Global
Messages : 2228
Enregistré le : 29 mai 2008, 14:59
Localisation : VAR
Contact :

Re: VNC: erreur de segmentation.

Message par nico8313 » 02 juin 2012, 19:23

:coucou:

Un serveur pourrait aussi très bien tourner sur un smart phone :thomas:
Je fais aussi tourner Radioactive@home sur mon EEEpc 900. Donc un Celeron 900Mhz

Pour ton serveur je n'ai pas d'idée. Peut-être Elgrande ou Dudu pour t'aiguiller :sifflote:

Avatar du membre
Elgrande71
Administrateur
Administrateur
Messages : 1728
Enregistré le : 29 février 2008, 10:24
Localisation : Le Creusot
Contact :

Re: VNC: erreur de segmentation.

Message par Elgrande71 » 02 juin 2012, 19:52

Salut cottesloe, :coucou:

première question,
Si oui, alors tu peux piloter ton PC via l'autre en utilisant le BOINC Manager (Menu Avancé puis Sélectionner un ordinateur)?
Dans Nom d'hôte, tu renseigneras l'adresse IP de ton serveur et dans l'autre champ ton mot de passe qui doit normalement se trouver dans le fichier gui_rpc_auth.cfg (situé dans /etc/boinc-client de ton PC serveur si tu as installé la version des dépôts).
Afin par contre, que ton serveur soit accessible par le BOINC Manager de ton autre PC, il faut que tu ais ajouté l'adresse IP du PC du BOINC Manager.
Ce réglage se trouve dans le fichier /etc/boinc-client/remote_hosts.cfg .
Personnellement, je pilote deux unités centrales par SSH et par BOINC Manager (installé sur un PC avec clavier, souris et écran), ceci sans aucun problème particulier.
Si tu veux d'autres explications, fait-nous signe ?
Je ne sais pas si mes explications sont claires car je suis réveillé depuis 3h30 du mat donc ça devient un peu dur d'avoir l'esprit clair.
Debian - Distribution GNU/Linux de référence
Parabola GNU/Linux - Distribution GNU/Linux Libre
Solus
Tux'N'Vape - Manjaro Tux'N'Vape

Avatar du membre
cottesloe
Modérateur Global
Modérateur Global
Messages : 329
Enregistré le : 23 juin 2010, 13:34
Localisation : Petersbach

Re: VNC: erreur de segmentation.

Message par cottesloe » 03 juin 2012, 10:50

Salut El :coucou:

Je viens de voir pour faire comme tu m'as dis.
Donc pour résumer et être sûr qu'on parle bien de la même chose, sur mon vieux PC Celeron qui est le serveur, j'ai ajouté à /etc/boinc-client/remote_hosts.cfg le nom et l'adresse IP de mon PC client, et à /etc/boinc-client/gui_rpc_auth.cfg j'ai ajouté un mot de passe, car il n'y avait rien. Fichier vide....

Sur le Celeron, si je lis le fichier de conf, j'ai bien le nom et l'IP du client qui apparaissent.
Mais, du PC client, si je sélectionne le serveur pour m'y connecter, en bas à droite il est inscrit "Connexion à 192.168.x.x en cours" et c'est tout. Ça n'évolue pas.
J'ai essayé en arrêtant le client connecté, et en me connectant sur le serveur, pas mieux...

Bref, je ne progresse pas... :prr:
Image
"Je sers la science et c'est ma joie"  Disciplus Simplex
Boinceur sous Archlinux 64 bits
La meilleure émission de radio, c'est la planète bleue

Avatar du membre
Elgrande71
Administrateur
Administrateur
Messages : 1728
Enregistré le : 29 février 2008, 10:24
Localisation : Le Creusot
Contact :

Re: VNC: erreur de segmentation.

Message par Elgrande71 » 03 juin 2012, 17:37

Pourrais-tu afficher le contenu du fichier /etc/default/boinc-client afin de savoir si la ligne suivante est décommentée :
BOINC_OPTS="--allow_remote_gui_rpc"

Normalement, c'est ce paramètre qui commande l'accès distant du client BOINC.
Debian - Distribution GNU/Linux de référence
Parabola GNU/Linux - Distribution GNU/Linux Libre
Solus
Tux'N'Vape - Manjaro Tux'N'Vape

Avatar du membre
cottesloe
Modérateur Global
Modérateur Global
Messages : 329
Enregistré le : 23 juin 2010, 13:34
Localisation : Petersbach

Re: VNC: erreur de segmentation.

Message par cottesloe » 03 juin 2012, 17:49

Effectivement, elle n'est pas décommentée...

Code : Tout sélectionner

# This file is /etc/default/boinc-client, it is a configuration file for the
# /etc/init.d/boinc-client init script.

# Set this to 1 to enable and to 0 to disable the init script.
ENABLED="1"

# Set this to 1 to enable advanced scheduling of the BOINC core client and
# all its sub-processes (reduces the impact of BOINC on the system's
# performance).
SCHEDULE="1"

# The BOINC core client will be started with the permissions of this user.
BOINC_USER="boinc"

# This is the data directory of the BOINC core client.
BOINC_DIR="/var/lib/boinc-client"

# This is the location of the BOINC core client, that the init script uses.
# If you do not want to use the client program provided by the boinc-client
# package, you can specify here an alternative client program.
#BOINC_CLIENT="/usr/local/bin/boinc"
BOINC_CLIENT="/usr/bin/boinc"

# Here you can specify additional options to pass to the BOINC core client.
# Type 'boinc --help' or 'man boinc' for a full summary of allowed options.
#BOINC_OPTS="--allow_remote_gui_rpc"
BOINC_OPTS=""
Je la décommente et je te dis quoi...
Image
"Je sers la science et c'est ma joie"  Disciplus Simplex
Boinceur sous Archlinux 64 bits
La meilleure émission de radio, c'est la planète bleue

Avatar du membre
Elgrande71
Administrateur
Administrateur
Messages : 1728
Enregistré le : 29 février 2008, 10:24
Localisation : Le Creusot
Contact :

Re: VNC: erreur de segmentation.

Message par Elgrande71 » 03 juin 2012, 17:52

Ah oui, il faudrait après relancer le client BOINC (sur le serveur) puis retenter une connexion depuis le BOINC Manager de l'autre PC.
Debian - Distribution GNU/Linux de référence
Parabola GNU/Linux - Distribution GNU/Linux Libre
Solus
Tux'N'Vape - Manjaro Tux'N'Vape

Avatar du membre
cottesloe
Modérateur Global
Modérateur Global
Messages : 329
Enregistré le : 23 juin 2010, 13:34
Localisation : Petersbach

Re: VNC: erreur de segmentation.

Message par cottesloe » 03 juin 2012, 18:15

Pareil mais pire....

Sur le PC serveur, je reste "déconnecté" en bas à droite et depuis le PC client, ça reste toujours "Connexion en cours"

Sur le PC serveur, si je lance Boinc par un terminal, j'ai ça...

Code : Tout sélectionner

sudo invoke-rc.d boinc-client start
 * Starting BOINC core client: boinc                                            non-network local connections being added to access control list
                                                                         [ OK ]
 * Setting up scheduling for BOINC core client and children:             [ OK ] 
Même en remettant /etc/default/boinc-client en conf d'origine, ça ne change rien....
J'ai tout cassé... :nico5:
Pourquoi les choses simples sont toujours compliquées??? :angry:
Image
"Je sers la science et c'est ma joie"  Disciplus Simplex
Boinceur sous Archlinux 64 bits
La meilleure émission de radio, c'est la planète bleue

Avatar du membre
cottesloe
Modérateur Global
Modérateur Global
Messages : 329
Enregistré le : 23 juin 2010, 13:34
Localisation : Petersbach

Re: VNC: erreur de segmentation.

Message par cottesloe » 03 juin 2012, 18:38

Sur le PC serveur, si je lance directement dans un terminal boinc, j'ai ça:

Code : Tout sélectionner

boinc
03-Jun-2012 18:34:25 [---] No config file found - using defaults
03-Jun-2012 18:34:25 [---] Starting BOINC client version 7.0.24 for i686-pc-linux-gnu
03-Jun-2012 18:34:25 [---] log flags: file_xfer, sched_ops, task
03-Jun-2012 18:34:25 [---] Libraries: libcurl/7.22.0 OpenSSL/1.0.1 zlib/1.2.3.4 libidn/1.23 librtmp/2.3
03-Jun-2012 18:34:25 [---] Data directory: /home/yallingup
03-Jun-2012 18:34:25 [---] Processor: 1 GenuineIntel Celeron (Coppermine) [Family 6 Model 8 Stepping 10]
03-Jun-2012 18:34:25 [---] Processor: 128.00 KB cache
03-Jun-2012 18:34:25 [---] Processor features: fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pse36 mmx fxsr sse up
03-Jun-2012 18:34:25 [---] OS: Linux: 3.2.0-24-generic
03-Jun-2012 18:34:25 [---] Memory: 494.95 MB physical, 243.00 MB virtual
03-Jun-2012 18:34:25 [---] Disk: 9.28 GB total, 8.52 GB free
03-Jun-2012 18:34:25 [---] Local time is UTC +2 hours
03-Jun-2012 18:34:25 [---] No usable GPUs found
03-Jun-2012 18:34:25 [---] No general preferences found - using defaults
03-Jun-2012 18:34:25 [---] Preferences:
03-Jun-2012 18:34:25 [---]    max memory usage when active: 247.48MB
03-Jun-2012 18:34:25 [---]    max memory usage when idle: 445.46MB
03-Jun-2012 18:34:25 [---]    max disk usage: 4.64GB
03-Jun-2012 18:34:25 [---]    don't use GPU while active
03-Jun-2012 18:34:25 [---]    suspend work if non-BOINC CPU load exceeds 25 %
03-Jun-2012 18:34:25 [---]    (to change preferences, visit the web site of an attached project, or select Preferences in the Manager)
dir_open: Could not open directory 'slots'.
03-Jun-2012 18:34:25 [---] GUI RPC bind to port 31416 failed: 98
gstate.init() failed
Error Code: -180
Si ça peux aider, moi, je n'y comprends pas grand chose, si ce n'est qu'il n'arrive plus à se connecter en localhost...
Image
"Je sers la science et c'est ma joie"  Disciplus Simplex
Boinceur sous Archlinux 64 bits
La meilleure émission de radio, c'est la planète bleue

Avatar du membre
Elgrande71
Administrateur
Administrateur
Messages : 1728
Enregistré le : 29 février 2008, 10:24
Localisation : Le Creusot
Contact :

Re: VNC: erreur de segmentation.

Message par Elgrande71 » 03 juin 2012, 19:33

Afin que le client puisse se reconnecter en localhost, il faudrait que tu ajoutes l'adresse 127.0.0.1 dans le fichier /etc/boinc-client/remote_hosts.cfg
Debian - Distribution GNU/Linux de référence
Parabola GNU/Linux - Distribution GNU/Linux Libre
Solus
Tux'N'Vape - Manjaro Tux'N'Vape

Avatar du membre
cottesloe
Modérateur Global
Modérateur Global
Messages : 329
Enregistré le : 23 juin 2010, 13:34
Localisation : Petersbach

Re: VNC: erreur de segmentation.

Message par cottesloe » 03 juin 2012, 20:04

Pas mieux... :prr:

Mais pourquoi faut-il lui spécifier de se connecter en local? Il ne le fait pas par défaut normalement?
Image
"Je sers la science et c'est ma joie"  Disciplus Simplex
Boinceur sous Archlinux 64 bits
La meilleure émission de radio, c'est la planète bleue

Avatar du membre
Elgrande71
Administrateur
Administrateur
Messages : 1728
Enregistré le : 29 février 2008, 10:24
Localisation : Le Creusot
Contact :

Re: VNC: erreur de segmentation.

Message par Elgrande71 » 03 juin 2012, 20:08

Que te dis la commande suivante dans un terminal ?
netstat -lt
Debian - Distribution GNU/Linux de référence
Parabola GNU/Linux - Distribution GNU/Linux Libre
Solus
Tux'N'Vape - Manjaro Tux'N'Vape

Avatar du membre
cottesloe
Modérateur Global
Modérateur Global
Messages : 329
Enregistré le : 23 juin 2010, 13:34
Localisation : Petersbach

Re: VNC: erreur de segmentation.

Message par cottesloe » 03 juin 2012, 20:14

Code : Tout sélectionner

netstat -lt
Connexions Internet actives (seulement serveurs)
Proto Recv-Q Send-Q Adresse locale          Adresse distante        Etat      
tcp        0      0 localhost.locald:domain *:*                     LISTEN     
tcp        0      0 *:ssh                   *:*                     LISTEN     
tcp        0      0 localhost.localdoma:ipp *:*                     LISTEN     
tcp        0      0 *:31416                 *:*                     LISTEN     
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN   
Voilà...
Je ne connaissais pas cette commande...
Image
"Je sers la science et c'est ma joie"  Disciplus Simplex
Boinceur sous Archlinux 64 bits
La meilleure émission de radio, c'est la planète bleue

Avatar du membre
Elgrande71
Administrateur
Administrateur
Messages : 1728
Enregistré le : 29 février 2008, 10:24
Localisation : Le Creusot
Contact :

Re: VNC: erreur de segmentation.

Message par Elgrande71 » 03 juin 2012, 20:24

C'est franchement bizarre car il n'y a rien de suspect.
Personnellement voici mon fichier /etc/default/boinc-client

# This file is /etc/default/boinc-client, it is a configuration file for the
# /etc/init.d/boinc-client init script.

# Set this to 1 to enable and to 0 to disable the init script.
ENABLED="1"

# Set this to 1 to enable advanced scheduling of the BOINC core client and
# all its sub-processes (reduces the impact of BOINC on the system's
# performance).
SCHEDULE="0"

# The BOINC core client will be started with the permissions of this user.
BOINC_USER="boinc"

# This is the data directory of the BOINC core client.
BOINC_DIR="/var/lib/boinc-client"

# This is the location of the BOINC core client, that the init script uses.
# If you do not want to use the client program provided by the boinc-client
# package, you can specify here an alternative client program.
#BOINC_CLIENT="/usr/local/bin/boinc"
BOINC_CLIENT="/usr/bin/boinc"

# Here you can specify additional options to pass to the BOINC core client.
# Type 'boinc --help' or 'man boinc' for a full summary of allowed options.
#BOINC_OPTS="--allow_remote_gui_rpc"
BOINC_OPTS=""

Je n'ai même pas allow_remote_gui_rpc et j'arrive à accéder à mes PC distants.
C'est à n'y rien comprendre.
Au niveau adresses IP, tes deux PCs sont bien au même niveau
Debian - Distribution GNU/Linux de référence
Parabola GNU/Linux - Distribution GNU/Linux Libre
Solus
Tux'N'Vape - Manjaro Tux'N'Vape

Avatar du membre
Elgrande71
Administrateur
Administrateur
Messages : 1728
Enregistré le : 29 février 2008, 10:24
Localisation : Le Creusot
Contact :

Re: VNC: erreur de segmentation.

Message par Elgrande71 » 03 juin 2012, 20:24

Et que te dis la commande netstat -aute ?
Debian - Distribution GNU/Linux de référence
Parabola GNU/Linux - Distribution GNU/Linux Libre
Solus
Tux'N'Vape - Manjaro Tux'N'Vape

Répondre