Page 1 sur 1

Ryzen plante avec YAFU

Posté : 28 octobre 2018, 12:51
par cguillem
Bonjour
Chez moi, YAFU plante instantanément avec les AMD ryzen 1800xet 2700x. Pas de problème avec Primegrid, Milkyway et autres. Si vous avez une expérience de la chose et une solution ? Merci d'avance.

Re: Ryzen plante avec YAFU

Posté : 29 octobre 2018, 20:07
par Elgrande71
Dans l'immédiat, je ne vois pas trop d'où cela pourrait venir .
Que dises les fichiers journaux systèmes ( dans /var/log ) comme kern.log , syslog etc ...

Re: Ryzen plante avec YAFU

Posté : 30 octobre 2018, 20:44
par cguillem
Merci de ta réponse, il y a des fichiers que je n'ai pas vérifié.
J'utilise Debian testing et n'ai rien trouvé de significatif dans le journal de Boinc et dmesg. Je vais devoir chercher de nouveau car je souhaite arrêter mon système 8350 et les séquences aliquotes m'intéressent beaucoup.
CG

Re: Ryzen plante avec YAFU

Posté : 31 octobre 2018, 22:56
par cguillem
cguillem a écrit :
28 octobre 2018, 12:51
Bonjour
Chez moi, YAFU plante instantanément avec les AMD ryzen 1800xet 2700x. Pas de problème avec Primegrid, Milkyway et autres. Si vous avez une expérience de la chose et une solution ? Merci d'avance.
La question est abordée ici : http://www.primegrid.com/forum_thread.php?id=7892

Re: Ryzen plante avec YAFU

Posté : 01 novembre 2018, 08:34
par alain65
Bonjour cguillem.

Tu es sous Arch? Sous quel noyau ?
Je ne pense pas le 4.15, mais si c'est le cas as tu essayé d'en changé dans un premier temps avant d'appliquer les
solutions données dans le forum Arch?
Je dis ça, car je ne vois nul part (j'ai peut être mal lu) que ce problème est lié aux ryzen, mais plutôt au kernel 4.15 (comme bien d'autres
soucis, malheureusement...)
Si oui, qu'est ce que ça a donné?

Re: Ryzen plante avec YAFU

Posté : 11 novembre 2018, 17:38
par cguillem
Bonjour,
Mon noyau est le 4.16.0-2-amd64 avec Debian testing. "vsyscall" est en cause et je ne vois pas de solution simple ou compréhensible par moi. Cela fait des mois que Yafu ne fonctionne plus, je peux attendre. Bon d'accord c'est un bête problème de compilation...
Merci de votre intérêt,
CG

Re: Ryzen plante avec YAFU

Posté : 13 novembre 2018, 17:22
par alain65
Bonjour Cguillem.

J'avais pas vu le post ou tu disais être sous debian, j'ai vu sur le lien que que tu donne qu'il était question de Arch...je n'ai pas été plus loin :sifflote:
cguillem a écrit :
11 novembre 2018, 17:38
Bon d'accord c'est un bête problème de compilation...
De quelle compilation parles tu? Je ne comprends pas..

Sinon j'ai relu le lien que tu as donné ainsi que ceux proposé dedans.
Hormi le fait qu'il s'agisse de Arch, cela concerne primgrid, pas YAFU.
En revanche, tu as raison, je pense que le problème peut être le même : «Selon le lien que vous avez partagé, le problème est que vsyscall est désactivé par défaut dans le dernier noyau » (tiré d'ici : https://translate.googleusercontent.com ... w#p1770266 )
Il pourrait donc bien s'agir d'une question de version de noyau. Tout le monde n'a pas ce problème car ça dépend du matériel.
Personnellement sur un seul de mes PC j'ai rencontré un problème similaire. Le problème a été résolu instantanément avec un retour
au noyau 4.13.

Ma question est: "As tu essayé la solution qui est proposée dans le lien que tu donne?"
C'est a dire d'ajouter : " vsyscall=emulate" à la ligne: " GRUB_CMDLINE_LINUX_DEFAULT=" "" , de ton grub?
(Voir le lien que j'ai mis au dessus).
Je ne pense pas, qu'il y ait de problème avec cette modification, si cela a résolu chez certains, pourquoi pas chez toi.
en revanche je te t'incite fortement à faire une copie de ton grub avant de le modifier (si ce n'est déjà fait):

Code : Tout sélectionner

cp /etc/default/grub grub.bak
Comme cela tu auras un copie de secours dans ton "home". En cas de problème, il te suffira de la copier dans l'autre sens en enlevant le .bak.

Sinon, y a toujours la possibilité de rétrograder de noyau... Ça serait malheureux qu'une des deux solutions ne fonctionne pas...

Re: Ryzen plante avec YAFU

Posté : 16 novembre 2018, 15:44
par cguillem
Bonjour,
J'ai essayé de mettre vsycall=none dans grub comme demandé dans dmesg ainsi que d'autres solutions proposées ailleurs, sans succès. Le noyau précédent causait le même problème. C'est Yafu qui doit être en cause.

Re: Ryzen plante avec YAFU

Posté : 18 novembre 2018, 03:07
par alain65
Bonjour cguillem

Pourquoi "vsyscall = none" ? Sur le lien vers arch il est dit que c'est "vsyscall = emulate", qu'il faut mettre dans le grub.
Es tu bien sur que dans ton dmesg il est demandé de mettre sur "none"? Moi je pense que c'est plutôt une information
justement comme quoi il n'a pas trouvé vsyscall. Il t'informe que "vsyscall = none"...Enfin, je dis ça, j'ai pas vu ton dmesg...

Pour le noyau, tu dis qu'avec l'ancien c'était pareil. De quel version s'agit il? Si c'était le 4.15, c'est normal, il est
bien dit dans les liens que tu as donné que le problème est apparu a partir du 4.15.
Comme dans mon cas, avec un autre projet qui partait en défaut (pas yafu c'est sur, mais me rappelle plus du quel....)
Il a fallu que je redescende en dessous du 4.15. Le 4.13 en l’occurrence.

Après si c'était bien un noyau inférieur au 4.15 que tu avais avant et que la modif du grub ne change rien, alors la
oui effectivement ça doit venir de YAFU. Mais je ne saurai t'en dire plus.

Re: Ryzen plante avec YAFU

Posté : 19 novembre 2018, 08:32
par Maeda
Ce serait pas au projet YAFU de recompiler ses applications avec un gcc récent ? J'ai eu ce problème il y a peu avec WCG, après qu'ils aient recompilé, plus de soucis !