Script de réinstallation pilotes ATI

Vous trouverez ici ,toutes les créations des membres de la mini-team : applications modifiées ou recompilées ... A vous de tester et de remonter les infos concernant d'éventuels bugs ou autres soucis.
Avatar du membre
otax
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 538
Enregistré le : 23 février 2008, 20:57
Localisation : Angoulême en Nouvelle Aquitaine ^^
Contact :

Re: Script de réinstallation pilotes ATI

Message par otax » 03 novembre 2011, 19:26

Ok, mais le peu que j'ai partent en erreur ....

Avatar du membre
jip
Administrateur
Administrateur
Messages : 2607
Enregistré le : 22 février 2008, 21:00
Localisation : Toulouse
Contact :

Re: Script de réinstallation pilotes ATI

Message par jip » 03 novembre 2011, 20:25

otax a écrit :Merci pour vos encouragements ! :jap:
Bon, je verrai si je passe à Gnome3 plus tard.

En attendant, au niveau de mon pilote ATI je dois remonter encore le temps ?

La version 11.8 puis la 11.7, etc ... jusqu'à ce que ça marche de nouveau avec Milky ?

Merci ++

Moi, je crois que je tourne toujours avec les 10.12 ....
Un synonyme, c'est un mot qu'on écrit pour remplacer celui dont on ne connait pas l'orthographe. (source inconnue). L'imagination est plus importante que le savoir. (Albert Einstein)

[align=center]Image[/align]

BoincLibristes, FreeTorrent, Ma brute

Avatar du membre
otax
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 538
Enregistré le : 23 février 2008, 20:57
Localisation : Angoulême en Nouvelle Aquitaine ^^
Contact :

Re: Script de réinstallation pilotes ATI

Message par otax » 03 novembre 2011, 22:34

Bon, ben c'est la panthère noire là !!!! :furax:

Rien à faire .. ni la 10.12, ni les autres pour faire tourner Milky.
Par contre Prime fonctionne avec toutes les versions ATI ... :murbric:

Je laisse tomber pour le moment ... :prr:

Avatar du membre
jip
Administrateur
Administrateur
Messages : 2607
Enregistré le : 22 février 2008, 21:00
Localisation : Toulouse
Contact :

Re: Script de réinstallation pilotes ATI

Message par jip » 03 novembre 2011, 22:43

Ben fait du prime en attendant de trouver ...

En plus en ce moment milky ..... pas top le fonctionnement ...
Un synonyme, c'est un mot qu'on écrit pour remplacer celui dont on ne connait pas l'orthographe. (source inconnue). L'imagination est plus importante que le savoir. (Albert Einstein)

[align=center]Image[/align]

BoincLibristes, FreeTorrent, Ma brute

Avatar du membre
Gillou40
Administrateur
Administrateur
Messages : 694
Enregistré le : 20 juin 2010, 07:40
Localisation : Mont de Marsan
Contact :

Re: Script de réinstallation pilotes ATI

Message par Gillou40 » 04 novembre 2011, 07:24

MilkyWay semble aller mieux.

Collatz marche pas mal non plus, mais il y a du pending .... :murbric:
Image

Avatar du membre
jip
Administrateur
Administrateur
Messages : 2607
Enregistré le : 22 février 2008, 21:00
Localisation : Toulouse
Contact :

Re: Script de réinstallation pilotes ATI

Message par jip » 05 novembre 2011, 17:36

tiens pas mal ça pour avoir direct le nouveau gnome avec la ubuntu 11.10 : http://ubuntu-gs-remix.sourceforge.net/p/download/

devrais être pas mal pour toi ça Otax ....
Un synonyme, c'est un mot qu'on écrit pour remplacer celui dont on ne connait pas l'orthographe. (source inconnue). L'imagination est plus importante que le savoir. (Albert Einstein)

[align=center]Image[/align]

BoincLibristes, FreeTorrent, Ma brute

Avatar du membre
Pascal94
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 643
Enregistré le : 16 mai 2009, 13:43
Localisation : France (94)
Contact :

Re: Script de réinstallation pilotes ATI

Message par Pascal94 » 05 novembre 2011, 18:19

si tu as déjà installé Ubuntu 11.10, il te suffit d'installer gnome-shell et gnome-panel depuis synaptic :coucou:
« Je ne sais pas quelles armes seront utilisées pour la troisième guerre mondiale, si elle a lieu. Mais la quatrième se règlera à coups de massues. » {Albert Einstein}

Avatar du membre
otax
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 538
Enregistré le : 23 février 2008, 20:57
Localisation : Angoulême en Nouvelle Aquitaine ^^
Contact :

Re: Script de réinstallation pilotes ATI

Message par otax » 05 novembre 2011, 21:40

Heu ... merci !

J'ai entendu qqun dire qu'on ne pouvait pas mettre de raccourcis sur le bureau avecGnome3.
J'essaierai, mais si c'est le cas, je reviendrai quand même à Unity.
Pour Mako, c'est quand même plus simple ...

++

Avatar du membre
Pascal94
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 643
Enregistré le : 16 mai 2009, 13:43
Localisation : France (94)
Contact :

Re: Script de réinstallation pilotes ATI

Message par Pascal94 » 06 novembre 2011, 00:58

bah moi j'ai mes raccourcis sur le bureau, et quand je passe sous Gnome 3, ils y sont toujours :jap:
« Je ne sais pas quelles armes seront utilisées pour la troisième guerre mondiale, si elle a lieu. Mais la quatrième se règlera à coups de massues. » {Albert Einstein}

Avatar du membre
nico8313
Modérateur Global
Modérateur Global
Messages : 2228
Enregistré le : 29 mai 2008, 14:59
Localisation : VAR
Contact :

Re: Script de réinstallation pilotes ATI

Message par nico8313 » 06 novembre 2011, 01:23

J'ai aussi des soucis avec Milky ! ça par en erreur de calcul ! (Sur HD 4850)
Sur Ubuntu 11.10 64bits avec unity ! pilote ATI Catalyst 11.8 et Boinc 6.10.58 installé avec le script Berkeley .
J'ai essayé avec d'autres projets comme primegrid (install de SDK OpenCL ) collatz, moo wrapper et ça marche ! :penseur:

j'ai installé OpenCL pensant qu'il le fallait peut-être avec milky mais non puisque c'est du Brook+ !
Peut-être que certaines librairies ne sont plus au même endroit ???

J'ai remarqué par exemple avec Collatz qu'il fallait mettre les lib dans /usr/lib64
hors maintenant avec Ubuntu 11.10 c'est à mettre dans /usr/lib/x86_64-Linux-gnu

enfin je cherche une piste ...

Avatar du membre
McDoul
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 71
Enregistré le : 12 février 2009, 20:46

Re: Script de réinstallation pilotes ATI

Message par McDoul » 06 novembre 2011, 03:03

Quand des librairies ne sont pas au bon endroit il suffit de faire des liens symboliques. Par exemple, une librairie est dans /usr/lib64 mais un projet la cherche dans /usr/lib/x86_64-Linux-gnu :

Code : Tout sélectionner

ln -s /usr/lib64/malibrairie.so /usr/lib/x86_64-Linux-gnu/

Avatar du membre
otax
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 538
Enregistré le : 23 février 2008, 20:57
Localisation : Angoulême en Nouvelle Aquitaine ^^
Contact :

Re: Script de réinstallation pilotes ATI

Message par otax » 06 novembre 2011, 11:35

Pascal94 a écrit :bah moi j'ai mes raccourcis sur le bureau, et quand je passe sous Gnome 3, ils y sont toujours :jap:
Intéressant ! :calin:

Donc si on les a fait avant c'est mieux ! :papy:
ça va peut-être le faire alors :penseur:

Avatar du membre
otax
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 538
Enregistré le : 23 février 2008, 20:57
Localisation : Angoulême en Nouvelle Aquitaine ^^
Contact :

Re: Script de réinstallation pilotes ATI

Message par otax » 06 novembre 2011, 11:50

nico8313 a écrit :J'ai aussi des soucis avec Milky ! ça par en erreur de calcul ! (Sur HD 4850)
Sur Ubuntu 11.10 64bits avec unity ! pilote ATI Catalyst 11.8 et Boinc 6.10.58 installé avec le script Berkeley .
J'ai essayé avec d'autres projets comme primegrid (install de SDK OpenCL ) collatz, moo wrapper et ça marche ! :penseur:

j'ai installé OpenCL pensant qu'il le fallait peut-être avec milky mais non puisque c'est du Brook+ !
Peut-être que certaines librairies ne sont plus au même endroit ???

J'ai remarqué par exemple avec Collatz qu'il fallait mettre les lib dans /usr/lib64
hors maintenant avec Ubuntu 11.10 c'est à mettre dans /usr/lib/x86_64-Linux-gnu

enfin je cherche une piste ...
Excellente remarque mon cher Nico !! :smak:
Je ne suis plus seul !! :tropfort:
J'en déduis que mon pb n'est ptet pas dans les drivers.

Du coup j'ai relancé la recherche avec l'idée des librairies aussi.
Mais je ne trouve pas d'erreur, sauf peut-etre la première ligne du ldd qui est bizarre :
linux-vdso.so.1 => (0x00007fff2bfff000)
root@UBU-64-TV:/home/otax/BOINC/projects/milkyway.cs.rpi.edu_milkyway# ldd milkyway_separation_0.82_x86_64-pc-linux-gnu__ati14
linux-vdso.so.1 => (0x00007fff2bfff000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007ff07b378000)
libaticalcl.so => /usr/lib/fglrx/libaticalcl.so (0x00007ff07b25a000)
libaticalrt.so => /usr/lib/fglrx/libaticalrt.so (0x00007ff07b139000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007ff07ae32000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007ff07ac1c000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007ff07a9fe000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007ff07a65f000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007ff07a457000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007ff07a252000)
libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007ff07a03f000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007ff079d07000)
/lib/ld-linux-x86-64.so.2 => /lib64/ld-linux-x86-64.so.2 (0x00007ff07b621000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007ff079aea000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007ff0798e7000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007ff0796e0000)
root@UBU-64-TV:/home/otax/BOINC/projects/milkyway.cs.rpi.edu_milkyway#
ça vous dit ?

> McDoul : merci de ta remarque. :jap:
Ptet qu'il y en aura besoin bientôt !

Avatar du membre
nico8313
Modérateur Global
Modérateur Global
Messages : 2228
Enregistré le : 29 mai 2008, 14:59
Localisation : VAR
Contact :

Re: Script de réinstallation pilotes ATI

Message par nico8313 » 06 novembre 2011, 13:08

Merci McDoul ! :tchin:

J'aurais encore appris une commande :grin: :jap:

J'y ai cru 5 minutes et je me suis dit que ça devait certainement être ça !
Puis ..... Pouffff erreur de calcul ! :murbric: :murbric: :murbric: :murbric: :furax:

Dans certains projets on peu voir le "Stderr output" qui informe de l'erreur de l'UT mais là ça dit pas grand chose !
a part ce qui est en gras !
http://milkyway.cs.rpi.edu/milkyway/res ... d=19352193
Stderr output
<core_client_version>6.10.58</core_client_version>
<![CDATA[
<message>
process exited with code 22 (0x16, -234)
</message>
<stderr_txt>
execv: No such file or directory <<<--------- ici
</stderr_txt>
]]>
Y manque un truc mal placé je suis sur :cavachier: :cavachier: :cavachier:

Avatar du membre
otax
Zone privée MT Libristes
Zone privée MT Libristes
Messages : 538
Enregistré le : 23 février 2008, 20:57
Localisation : Angoulême en Nouvelle Aquitaine ^^
Contact :

Re: Script de réinstallation pilotes ATI

Message par otax » 06 novembre 2011, 22:33

Pascal94 a écrit :si tu as déjà installé Ubuntu 11.10, il te suffit d'installer gnome-shell et gnome-panel depuis synaptic :coucou:
Bizarre, gnome panel y est déjà.
Juste le gnome shell à mettre.

C'est sûr que je reviendrai sans problème à Unity ?
:sifflote:

Répondre